(Solved!) How on earth do I change the language?

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
Post Reply
DonnyZ
Posts: 1
Joined: Tue Mar 05, 2024 8:33 pm

(Solved!) How on earth do I change the language?

Post by DonnyZ »

EDIT - SOLUTION: Go to InstallDirectoryWherever\Freeciv\share\locale, shift-select all languages other than en_GB, then hold shift, press delete. Enjoy. I sure did.
EDIT 2 - BETTER SOLUTION: In the start menu, search for Freeciv, when you find it, right click - open file location. You should now be in the start subfolder containing the shortcut to the game. Right click it, properties, in the target box make sure it's:

Code: Select all

C:\WhereverYouInstalledIt\Freeciv\freeciv-something.cmd en_US

En_US forces it on english. Then hold ctrl, drag the shortcut to desktop (this will copy it), and you're done!
[/b]

Original post:
Why make it so the game AUTOMATICALLY PICKS YOUR REGION LANGUAGE?!?!? I picked english when installing. Some guides I found online said I should modify the shortcut from something about "auto" to the language I want (then english can be en, en-us...) but the installer didn't even put a shortcut on my desktop.

Please, for the love of God, how do I set freeciv to english? :o

Oh and NOPE, no Language option in Settings, ofc I wouldn't be here otherwise.

Oh and my system language is also, guessed it! ENGLISH. (proof in one of the attachments)
Attachments
Screenshot 2024-03-05 224008.png
Screenshot 2024-03-05 224008.png (11.18 KiB) Viewed 2817 times
Screenshot 2024-03-05 223432.png
Screenshot 2024-03-05 223432.png (489.76 KiB) Viewed 2819 times
Post Reply