Mismatch client/server version?

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
Post Reply
Lachu
Elite
Posts: 446
Joined: Sat May 04, 2013 2:19 pm

Mismatch client/server version?

Post by Lachu »

I am developing freeciv. I cannot found information about how to solve server/client version mismatch. I update freeciv from git sources to apply my work at top of latest version. That is normal freeciv had different client/server version on master branch? How to life with this problem?
cazfi
Elite
Posts: 2457
Joined: Tue Jan 29, 2013 6:54 pm

Re: Mismatch client/server version?

Post by cazfi »

Lachu wrote: Fri Jun 17, 2022 6:24 pmThat is normal freeciv had different client/server version on master branch?
Err... the same version (in this case: master HEAD) is the same version. Sounds like you're using the other part (of client/server) from some other build.
Lachu
Elite
Posts: 446
Joined: Sat May 04, 2013 2:19 pm

Re: Mismatch client/server version?

Post by Lachu »

You are right.

I do not known, what I messed up. I do git pull --rebase origin master && make && ( ./fcgui & ./fcser )

Everything works, sorry.
Post Reply