Compile sdl client

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
jury
Posts: 2
Joined: Fri Jan 18, 2019 5:33 pm

Compile sdl client

Postby jury » Fri Jan 18, 2019 5:44 pm

Hi
I would like to compile SDL 1 client, but configure gives errors. I have read the INSTALL file and it seems that I meet all the prequisities, but command:

Code: Select all

./configure --enable-client=sdl


gives me this:

Code: Select all

...
checking for GGZ library: libggz... no
checking for GGZ library: libggz... (cached) no
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.7... yes
checking for GTK+ - version >= 2.12.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GTK+ is incorrectly installed.
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 3.0.0... Package gtk+-3.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-3.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-3.0' found
no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GTK+ is incorrectly installed.
checking Qt5 headers... not found
configure: error: Cannot build modpack installer with any gui


I even tried to disable gtk tests:

Code: Select all

./configure --disable-gtktest --enable-client=sdl


But the error is the same. How to compile sdl client? Freeciv version is 2.5.9

cazfi
Elite
Posts: 1720
Joined: Tue Jan 29, 2013 6:54 pm

Re: Compile sdl client

Postby cazfi » Fri Jan 18, 2019 6:19 pm

jury wrote:

Code: Select all

configure: error: Cannot build modpack installer with any gui

Try '--disable-fcmp' to disable build of modpack installer utility.
jury wrote:Freeciv version is 2.5.9

Why such an old version? Latest stable release is 2.6.0. If you want to remain 2.5 compatible, latest bugfix release of that branch is 2.5.11.

jury
Posts: 2
Joined: Fri Jan 18, 2019 5:33 pm

Re: Compile sdl client

Postby jury » Fri Jan 18, 2019 8:13 pm

Yes, I want to remail 2.5 compatibile, but I somehow missed that there was anything above 2.5.9, so will try this 2.5.11 then.

cazfi wrote:Try '--disable-fcmp' to disable build of modpack installer utility.


Yes, this helped. I'm in the make process now.
Thank you!