prepare_freeciv.sh

Web version of freeciv at play.freeciv.org
Orisson
Posts: 6
Joined: Sat Mar 03, 2018 12:46 pm

prepare_freeciv.sh

Postby Orisson » Tue May 08, 2018 9:49 pm

Hi,

when i run ./prepare_freeciv.sh

i get :
Capstring to be replaced does not match one given in version.txt
Patching failed


In version.txt we have
FCREV=5b941ee273ca2e0cd2adab72c74c8d7972a70ecf
ORIGCAPSTR="+Freeciv.Devel-3.1-2018.May.06"
WEBCAPSTR="+Freeciv.Web.Devel-3.1"


In fc_version we have
NETWORK_CAPSTRING_MANDATORY="+Freeciv.Devel-3.1-2018.May.06"

madmax
Posts: 38
Joined: Sun Mar 26, 2017 5:34 pm

Re: prepare_freeciv.sh

Postby madmax » Wed May 09, 2018 2:54 pm

Maybe you have grep aliased to egrep or grep -E?

Orisson
Posts: 6
Joined: Sat Mar 03, 2018 12:46 pm

Re: prepare_freeciv.sh

Postby Orisson » Thu May 10, 2018 12:57 pm

Nope.

I have replaced this
if ! grep "NETWORK_CAPSTRING_MANDATORY=\"$ORIGCAPSTR\"" freeciv/fc_version 2>/dev/null >/dev/null ; then

by
if ! grep -rl "NETWORK_CAPSTRING_MANDATORY=\"$ORIGCAPSTR\"" . 2>/dev/null >/dev/null ; then

and it works.

I had to manually download the freeciv folder, so i think that was the problem.