bugs in 2.5.3 and 2.5.4

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
sveinung
Elite
Posts: 430
Joined: Wed Feb 20, 2013 4:50 pm

Re: bugs in 2.5.3

Postby sveinung » Wed Jun 01, 2016 12:23 pm

fomalhaut wrote:3. Spy can't empty the granary by poisoning the water supply.

See patch #7241 and bug #24720.

fomalhaut
Posts: 36
Joined: Thu Feb 13, 2014 8:24 am
Location: Japan

Re: bugs in 2.5.3 and 2.5.4

Postby fomalhaut » Sun Jun 05, 2016 3:31 pm

Additionally, I want to fix following two bugs in ver 2.5.4.

9. Following error message is displayed at the start of the game.
"in package_player_info() [../../../../server/plrhand.c::1013]: assertion '!game_was_started()' failed."
Several players are on the same team and 'plrcolormode' : "PLR_RANDOM"'

10. When I fail to connect to network game, an unreadable message is displayed.
(Please try to connect to localhost, port 5556)

cazfi
Elite
Posts: 1720
Joined: Tue Jan 29, 2013 6:54 pm

Re: bugs in 2.5.3 and 2.5.4

Postby cazfi » Sun Jun 26, 2016 7:34 am

fomalhaut wrote:9. Following error message is displayed at the start of the game.
"in package_player_info() [../../../../server/plrhand.c::1013]: assertion '!game_was_started()' failed."
Several players are on the same team and 'plrcolormode' : "PLR_RANDOM"'

Do you give initial techs for the players? Either in the ruleset, or maybe the bug I'm thinking applies even with the techlevel server setting. This sounds like already fixed bug #24614.

cazfi
Elite
Posts: 1720
Joined: Tue Jan 29, 2013 6:54 pm

Re: bugs in 2.5.3 and 2.5.4

Postby cazfi » Sun Jun 26, 2016 9:02 am

fomalhaut wrote:4. If sea unit is inside a city, their winning percentage against enemy units is always displayed as 0%.

-> bug #24799.

I've almost finished a fix.

fomalhaut
Posts: 36
Joined: Thu Feb 13, 2014 8:24 am
Location: Japan

Re: bugs in 2.5.3 and 2.5.4

Postby fomalhaut » Sat Jul 16, 2016 2:53 am

cazfi wrote:
fomalhaut wrote:9. Following error message is displayed at the start of the game.
"in package_player_info() [../../../../server/plrhand.c::1013]: assertion '!game_was_started()' failed."
Several players are on the same team and 'plrcolormode' : "PLR_RANDOM"'

Do you give initial techs for the players? Either in the ruleset, or maybe the bug I'm thinking applies even with the techlevel server setting. This sounds like already fixed bug #24614.


No, this error is not related with initial techs.
/team "AI*1" "Team 0"
/team "AI*2" "Team 0"
/set plrcolormode "PLR_RANDOM"'
just this

User avatar
JTN
Elite
Posts: 462
Joined: Wed Jan 30, 2013 12:15 am

Re: bugs in 2.5.3 and 2.5.4

Postby JTN » Sat Jul 16, 2016 9:18 am

fomalhaut wrote:
cazfi wrote:This sounds like already fixed bug #24614.

/set plrcolormode "PLR_RANDOM"'

That 'plrcolormode' can certainly trigger bug #24614, which will be fixed in 2.5.5.