Issues with multiplayer loaded game [Freeciv-web]

Web version of freeciv at play.freeciv.org
WanderingDude
Posts: 6
Joined: Sun Jan 17, 2016 2:24 pm

Issues with multiplayer loaded game [Freeciv-web]

Postby WanderingDude » Sun Jan 17, 2016 3:29 pm

Hello everyone, nice to meet you. I am new here but used to play lots of Freeciv back in the day.
I have only recently discovered Freeciv-web and I love it, since it allows me to play with friends online.
Or so I thought...

We played a multiplayer game for hours and then saved it.
I was the game creator and when the day after I was going to load the savegame, all seemed fine.

Unfortunately it turns out my friend can't control any of their units once they re-join the game.
Let's see if we are doing this right first of all...

a) I go on https://play.freeciv.org/ and click Load Game button
b) I enter my initial Player name and click Customize game
c) I select the latest savegame from the night we played and load it
d) in the Settings, I enter again the password to make it protected
d) this is when I tell my friend the game is live
e) she goes to https://play.freeciv.org/ and clicks on Multiplayer games
f) she switches tab to Single-player games
g) she scrolls down until she finds the game I just reloaded, and clicks Observe
h) enters Player name and goes in - initially she sees the whole map
i) in the chat box, she types: /take XYZ (where XYZ is the name of the nation she was playing the other night)
j) I get a message in the chat box that the civilization XYZ is now under my friend's human control
k) she can now see the original worldmap she had explored last night
l) all happy? NO :( she can't click on any of her units, or enter any of her cities. She doesn't actually control her nation
*m) I tried to take over her nation by using the same /take command, and I can effectively control it. even more bizarre

What are we doing wrong? Or is it a bug?

Thanks a million, I would love to play more freeciv-web... Sorry for long post!!

User avatar
AndreasR
Elite
Posts: 702
Joined: Thu May 02, 2013 10:26 pm
Location: Norway

Re: Issues with multiplayer loaded game [Freeciv-web]

Postby AndreasR » Sun Jan 17, 2016 8:34 pm

Hi and thanks for the bugreport. Savegames does not work with multiplayer games at the moment. I will fix this in the next version.

Andreas

WanderingDude
Posts: 6
Joined: Sun Jan 17, 2016 2:24 pm

Re: Issues with multiplayer loaded game [Freeciv-web]

Postby WanderingDude » Sun Jan 17, 2016 8:35 pm

Thank you Andreas!

Do you have a vague timeframe for the next version's release?
Out of curiosity.

User avatar
AndreasR
Elite
Posts: 702
Joined: Thu May 02, 2013 10:26 pm
Location: Norway

Re: Issues with multiplayer loaded game [Freeciv-web]

Postby AndreasR » Sun Jan 17, 2016 8:38 pm

WanderingDude wrote:Thank you Andreas!

Do you have a vague timeframe for the next version's release?
Out of curiosity.


I hope to fix this by next Sunday.

Andreas

WanderingDude
Posts: 6
Joined: Sun Jan 17, 2016 2:24 pm

Re: Issues with multiplayer loaded game [Freeciv-web]

Postby WanderingDude » Sun Jan 17, 2016 8:45 pm

Amazing.
Thank you.

User avatar
AndreasR
Elite
Posts: 702
Joined: Thu May 02, 2013 10:26 pm
Location: Norway

Re: Issues with multiplayer loaded game [Freeciv-web]

Postby AndreasR » Sat Jan 23, 2016 1:19 pm

I think loading of multiplayer games should work correctly now. Could you please give it a try?

Andreas