Combat Animation Not Displaying on Kubuntu with Oxygen theme

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
cazfi
Elite
Posts: 1710
Joined: Tue Jan 29, 2013 6:54 pm

Re: Combat Animation Not Displaying

Postby cazfi » Sat May 04, 2013 6:21 pm

I'm just downloading 64bit Kubuntu 13.04 to install in a virtual machine for testing if I can reproduce the issue with such an setup.

cazfi
Elite
Posts: 1710
Joined: Tue Jan 29, 2013 6:54 pm

Re: Combat Animation Not Displaying

Postby cazfi » Sun May 05, 2013 7:46 pm

Seems to be related to Ubuntu's gtk+ modifications.

Both combat and movement animations are affected, so I tested by simply setting very high movement animation time. Either unit moved slowly, or nothing happened for a while and then unit teleported to destination.

Kubuntu's freeciv + Kubuntu's libgtk+ -> doesn't work
Our freeciv trunk + Kubuntu's libgtk+ -> doesn't work
Our freeciv trunk + Upstream libgtk+ 2.24.17 (same version as Kubuntu's base) -> works

louis94
Hardened
Posts: 219
Joined: Thu Apr 25, 2013 10:17 pm
Location: Belgium

Re: Combat Animation Not Displaying

Postby louis94 » Sun May 05, 2013 9:45 pm

(Animations in the Sdl client do work.)
So does really Ubuntu break Gtk+, or does Freeciv have some special requirement ?

I also got Xorg using up to 1Gb memory and using 100% of 1 cpu core after having played Freeciv for hours. Maybe it's also related to Ubuntu's Gtk+, since it doesn't happen in Fedora. Might also be related to the AMD proprietary drivers, or to the oxygen-gtk widget style.

Louis

mililani
Posts: 7
Joined: Wed May 01, 2013 11:12 pm

Re: Combat Animation Not Displaying

Postby mililani » Sun May 05, 2013 10:58 pm

louis94 wrote:Might also be related to the AMD proprietary drivers, or to the oxygen-gtk widget style.


Thanks! That seems to be indeed the case. Switching from oxygen-gtk to the other style installed by default (Raleigh) does the trick. :!:

louis94
Hardened
Posts: 219
Joined: Thu Apr 25, 2013 10:17 pm
Location: Belgium

Re: Combat Animation Not Displaying

Postby louis94 » Mon May 06, 2013 5:19 pm

Reported here
See also: this about Freeciv and Oxygen

Feedback from the Oxygen team:
Setting

Code: Select all

export OXYGEN_DISABLE_INNER_SHADOWS_HACK=1

before running Freeciv make animations work.

Louis
Last edited by louis94 on Wed May 08, 2013 7:45 am, edited 1 time in total.

User avatar
JTN
Elite
Posts: 462
Joined: Wed Jan 30, 2013 12:15 am

Re: Combat Animation Not Displaying on Kubuntu with Oxygen t

Postby JTN » Tue May 07, 2013 7:34 pm

Excellent, thanks for digging that up. I've edited the first post to point to this explanation/workaround.

mililani
Posts: 7
Joined: Wed May 01, 2013 11:12 pm

Re: Combat Animation Not Displaying on Kubuntu with Oxygen t

Postby mililani » Tue May 07, 2013 11:16 pm

Just as an addendum: while both methods work fine on my laptop, my desktop with two monitors still exhibits the problem, no matter how I set the environment variable or change the GTK theme.