Change Language

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
Antiscamp
Posts: 2
Joined: Sat Feb 01, 2014 5:44 pm

Change Language

Postby Antiscamp » Sat Feb 01, 2014 5:49 pm

Hey,

I downloaded FreeCiv SDL today and played a couple of thousand years. I saved the game and now, when I'm reloading it, the game has changed to Swedish, which is the language my computer speaks. I don't like that. It's unimmersive and the translation is also quite badly done. How do I change it back to English so i can continue playing? I can find nothing in the game's settings.

cazfi
Elite
Posts: 1718
Joined: Tue Jan 29, 2013 6:54 pm

Re: Change Language

Postby cazfi » Sat Feb 01, 2014 6:12 pm

It sounds like a bug if it was in English first and then switched to Swedish on next launch.

Is it possible that you selected "Autodetect" as the language choice when installing (so it would pick up Swedish as the Windows language) and then launched Freeciv directly from the installer (the time it was in English)?

I don't have Windows machine to check this just now, but right-clicking on the freeciv icon and selecting "Properties" (or Swedish equivalent) should bring up dialog where you can adjust parameters passed to the .cmd file. Make first parameter "en_US" or "en_UK" depending which one you prefer. Currently there might be no parameters, or the parameter in question can be "auto" or "se".

Antiscamp
Posts: 2
Joined: Sat Feb 01, 2014 5:44 pm

Re: Change Language

Postby Antiscamp » Sat Feb 01, 2014 6:38 pm

Thanks for the reply. You actually led me on the right track in my thought process. I just removed the SV folder from the locale folder in FreeCiv. It's working like a charm in the Queen's English :)