Page 2 of 2

Re: The sounds won't work

Posted: Thu May 24, 2018 7:37 pm
by Arbogast
I don't have sounds either!
Running on 2.6 with GTK2 and since this morning, no Sounds! All my cables and speakers are OK.
So, this is a glitch in Freeciv, ain't it?

Re: The sounds won't work

Posted: Wed May 30, 2018 4:50 pm
by Steve R.
cazfi wrote:
Steve R. wrote:Then followed the directions from this website: http://linuxg.net/how-to-install-freeci ... e-systems/
btw. I don't recommend that way of building and installing, since there's no easy way to uninstall. Even if you are fine having some version of freeciv permanently in your system, this can cause trouble also when "updating". If there are some files in the older version that are not in the newer version, those are left to the system when overwriting stuff with the new version. There has been some cases in the past where such leftover files with old (incompatible with current freeciv installation) file formats have caused problems.
The way I recommend one to do compilations can be seen from viewtopic.php?f=8&t=89944
You have pointed out an obvious concern. The method that I used did NOT include the packages necessary for sound, hence my post. Following the help here, solved the sound problem. However, I have been somewhat bewildered by a lack of an easily found and obvious install sticky on the forum. Seems that there are a significant number of people who could use a sticky outlining how to remove an old version and install a new version.

Re: The sounds won't work

Posted: Wed May 30, 2018 5:03 pm
by Steve R.
Arbogast wrote:I don't have sounds either!
Running on 2.6 with GTK2 and since this morning, no Sounds! All my cables and speakers are OK.
So, this is a glitch in Freeciv, ain't it?


For me, the following two packages needed to be installed before compiling freeciv, based prior posts in this thread. So if you already have a compiled version, you will need to uninstall it. I suspected that was the case as I had no sound when I activated freeciv. Re-installing freeciv solved the sound problem. See the prior posts in this thread for the source of the code below.

Code: Select all

sudo apt install freeciv-sound-standard


and

Code: Select all

apt-get install libsdl2-mixer-dev


I have no idea if one has to be installed first and then followed by the other.
After installing these two programs, I went through the whole process of compiling freeciv. The sound worked. Yeah.

Re: The sounds won't work

Posted: Fri Jun 22, 2018 3:50 pm
by Arbogast
Steve R: thanks for your tips, I have solved the problem.