Page 2 of 2

Re: bugs in 2.5.3

Posted: Wed Jun 01, 2016 12:23 pm
by sveinung
fomalhaut wrote:3. Spy can't empty the granary by poisoning the water supply.

See patch #7241 and bug #24720.

Re: bugs in 2.5.3 and 2.5.4

Posted: Sun Jun 05, 2016 3:31 pm
by fomalhaut
Additionally, I want to fix following two bugs in ver 2.5.4.

9. Following error message is displayed at the start of the game.
"in package_player_info() [../../../../server/plrhand.c::1013]: assertion '!game_was_started()' failed."
Several players are on the same team and 'plrcolormode' : "PLR_RANDOM"'

10. When I fail to connect to network game, an unreadable message is displayed.
(Please try to connect to localhost, port 5556)

Re: bugs in 2.5.3 and 2.5.4

Posted: Sun Jun 26, 2016 7:34 am
by cazfi
fomalhaut wrote:9. Following error message is displayed at the start of the game.
"in package_player_info() [../../../../server/plrhand.c::1013]: assertion '!game_was_started()' failed."
Several players are on the same team and 'plrcolormode' : "PLR_RANDOM"'

Do you give initial techs for the players? Either in the ruleset, or maybe the bug I'm thinking applies even with the techlevel server setting. This sounds like already fixed bug #24614.

Re: bugs in 2.5.3 and 2.5.4

Posted: Sun Jun 26, 2016 9:02 am
by cazfi
fomalhaut wrote:4. If sea unit is inside a city, their winning percentage against enemy units is always displayed as 0%.

-> bug #24799.

I've almost finished a fix.

Re: bugs in 2.5.3 and 2.5.4

Posted: Sat Jul 16, 2016 2:53 am
by fomalhaut
cazfi wrote:
fomalhaut wrote:9. Following error message is displayed at the start of the game.
"in package_player_info() [../../../../server/plrhand.c::1013]: assertion '!game_was_started()' failed."
Several players are on the same team and 'plrcolormode' : "PLR_RANDOM"'

Do you give initial techs for the players? Either in the ruleset, or maybe the bug I'm thinking applies even with the techlevel server setting. This sounds like already fixed bug #24614.


No, this error is not related with initial techs.
/team "AI*1" "Team 0"
/team "AI*2" "Team 0"
/set plrcolormode "PLR_RANDOM"'
just this

Re: bugs in 2.5.3 and 2.5.4

Posted: Sat Jul 16, 2016 9:18 am
by JTN
fomalhaut wrote:
cazfi wrote:This sounds like already fixed bug #24614.

/set plrcolormode "PLR_RANDOM"'

That 'plrcolormode' can certainly trigger bug #24614, which will be fixed in 2.5.5.