compiling problem with libtool

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
User avatar
Handbanana
Posts: 1
Joined: Mon Aug 10, 2015 12:03 am

compiling problem with libtool

Postby Handbanana » Mon Aug 10, 2015 12:30 am

Perhaps this is more of a libtool issue than something with Freeciv, but I figure that since it's for Freeciv, people here can probably be of help.

I'm compiling the latest stable version of Freeciv on Windows using MinGW and Cygwin. Mostly everything has passed ./configure and make install without trouble, but libtool seems to keep returning errors, and I can't for the life of me figure out what is wrong.

I have followed every step of the installation page for Windows on the wiki, and my directories look like this:

C:\
C:\ProgramDev\
C:\ProgramDev\Cygwin\
C:\ProgramDev\Cygwin\usr\share\automake-1.15 etc...
C:\ProgramDev\Cygwin\usr\share\libtool-2.4.6\
C:\ProgramDev\MinGW\

I downloaded the tarball for libtool 2.4.6 and it had no problems with ./configure, but when I then run make install, it does this:

Code: Select all

Leif@Leif_PC /usr/share/libtool-2.4.6
$ make install
make  install-recursive
make[1]: Entering directory '/usr/share/libtool-2.4.6'
Making install in .
make[2]: Entering directory '/usr/share/libtool-2.4.6'
  CCLD     libltdl/libltdl.la
/usr/share/libtool-2.4.6/libltdl/.libs/dlopen.a: No such file or directory
C:\ProgramDev\MinGW\bin\ar.exe: Makefile:1136: recipe for target 'libltdl/libltdl.la' failed
make[2]: *** [libltdl/libltdl.la] Error 9
make[2]: Leaving directory '/usr/share/libtool-2.4.6'
Makefile:1606: recipe for target 'install-recursive' failed
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory '/usr/share/libtool-2.4.6'
Makefile:1908: recipe for target 'install' failed
make: *** [install] Error 2


I would like to point out that /usr/share/libtool-2.4.6/libltdl/.libs/dlopen.a is there, so I don't know what that is all about.

Anyway, this has been driving me nuts, and it's the last thing I need to do before I can compile Freeciv itself, so I would greatly appreciate any help. Thank you.
Tonight... you.

cazfi
Elite
Posts: 1710
Joined: Tue Jan 29, 2013 6:54 pm

Re: compiling problem with libtool

Postby cazfi » Mon Aug 10, 2015 4:16 am

While I have no idea of what's the cause of your libtool build problem, I wonder if you really need to do that. If your goal is just to compile freeciv, you should be able to use ready-made binaries of those tools.

1) If you want to use Cygwin: Cygwin already has all the needed packages available. List of needed packages in doc/INSTALL.Cygwin should be up to date (it's over a year since I last made cygwin build, but things should have not changed so much in the stable branches)

2) As a MinGW you can use environment made for freeciv as comments in the top of win32/installer/Makefile document. No prior MinGW installation required.