Page 1 of 2

Browser version does not work in Chrome

Posted: Thu May 16, 2013 4:32 pm
by colesmills
I can't get the Browser version of FreeCiv to work! I navigate to http://play.freeciv.org/webclient/ and click "start game" in the popup window but the game screen is black and it does not start. Is there anything I'm doing wrong?

Re: Browser version does not work in Chrome

Posted: Fri May 17, 2013 6:22 pm
by randscreen
I'm seeing the same problem on iPhone 5 with both the Safari and Chrome browsers.

Re: Browser version does not work in Chrome

Posted: Sat May 18, 2013 10:16 pm
by louis94
Hello,

It doesn't work in QtWebKit 4.8.1 (Rekonq). All Webkit browsers seem to be affected.
Konqueror also fails to load the game, but Konq is not as important as Chrome & al.

Louis

Re: Browser version does not work in Chrome

Posted: Mon May 20, 2013 5:43 pm
by ifaesfu
I tried to start a multiplayer game and observe an existing one and I had no problems with Google Chrome. It was 2 days ago.

Re: Browser version does not work in Chrome

Posted: Tue May 21, 2013 3:10 pm
by AndreasR
Hi colesmills, randscreen and louis94!

Thanks for reporting the issues with the Freeciv web client. This is something we should fix! 8-)

Could you please try playing the game again now, and see if you still get the same problems?
If the problem still remains, then please give as much information as possible about:
- web browser version
- operating system
- Internet connection speed
- plugins installed in the browser
- if you are connecting through a HTTP proxy
- if you have any problems with other HTML5 games which use websockets, eg http://rumpetroll.com/
- error messages in the Javascript console of your browser.

Please give as much information as possible. Thanks for your bugreports!

Andreas

Re: Browser version does not work in Chrome

Posted: Tue May 21, 2013 4:18 pm
by louis94
Hello,

Here is the requested information:
- web browser version
Rekonq 2.3.0 (http://rekonq.kde.org), or any based upon QtWebkit from Qt 4.8 (just tested using Qt Designer).
- operating system
Kubuntu Linux 12.10 with Project Neon's PPA.
- Internet connection speed
Up to 2.5 Mio/s.
- plugins installed in the browser
Not relevant since it does not work with a simple QtWebkit widget.
- if you are connecting through a HTTP proxy
No.
- if you have any problems with other HTML5 games which use websockets, eg http://rumpetroll.com/
No.
- error messages in the Javascript console of your browser.
Failed to load resource: Blocked by « adfilter » -> analytics.js
http://play.freeciv.org -> Unexpected response code: 426
webclient.js:81 -> WebSocket connection closed.

Request to ws://play.freeciv.org/civsocket is pending for a long time.

Louis

Re: Browser version does not work in Chrome

Posted: Tue May 21, 2013 5:54 pm
by AndreasR
Thanks for all the useful debugging information. Today I learned that I had to start testing for yet another browser called Rekonq.

I got Freeciv-web running on Rekonq 2.2.1 on Ubuntu. However, I haven't been able to compile your version on Ubuntu yet.

Could you please test Freeciv-web on Firefox 21 or Google Chrome if you have access? I would like to find out of this problem is specific to
some browser, or if there is some other thing with your system which causes this.

"Unexpected response code: 426" seems to be the relevant error message.

Re: Browser version does not work in Chrome

Posted: Tue May 21, 2013 6:14 pm
by louis94
Works for me in Chromium 25.0 and Firefox 21, but still not in QtWebkit.

Re: Browser version does not work in Chrome

Posted: Tue May 21, 2013 6:54 pm
by AndreasR
louis94 wrote:Works for me in Chromium 25.0 and Firefox 21, but still not in QtWebkit.


Very interesting. Some versions of QtWebkit is the problem then. I'll give Rekonq on Kubuntu a try when I get the chance.
The problem could actually be a bug in QtWebkit. Or perhaps a bug in nginx (HTTP proxy used by Freeciv-web) or the Tornado (python webserver).

Just to be clear, Freeciv-web works correctly for most people using the latest versions of Firefox, Chrome and Safari?
I'm trying to figure out of this issue will have an effect for most users, or if it is only for very specific versions of some browsers.

Andreas

Re: Browser version does not work in Chrome

Posted: Wed May 22, 2013 8:52 am
by Caedo
It works perfect for me with Firefox 21.