Page 2 of 2

Re: Combat Animation Not Displaying

Posted: Sat May 04, 2013 6:21 pm
by cazfi
I'm just downloading 64bit Kubuntu 13.04 to install in a virtual machine for testing if I can reproduce the issue with such an setup.

Re: Combat Animation Not Displaying

Posted: Sun May 05, 2013 7:46 pm
by cazfi
Seems to be related to Ubuntu's gtk+ modifications.

Both combat and movement animations are affected, so I tested by simply setting very high movement animation time. Either unit moved slowly, or nothing happened for a while and then unit teleported to destination.

Kubuntu's freeciv + Kubuntu's libgtk+ -> doesn't work
Our freeciv trunk + Kubuntu's libgtk+ -> doesn't work
Our freeciv trunk + Upstream libgtk+ 2.24.17 (same version as Kubuntu's base) -> works

Re: Combat Animation Not Displaying

Posted: Sun May 05, 2013 9:45 pm
by louis94
(Animations in the Sdl client do work.)
So does really Ubuntu break Gtk+, or does Freeciv have some special requirement ?

I also got Xorg using up to 1Gb memory and using 100% of 1 cpu core after having played Freeciv for hours. Maybe it's also related to Ubuntu's Gtk+, since it doesn't happen in Fedora. Might also be related to the AMD proprietary drivers, or to the oxygen-gtk widget style.

Louis

Re: Combat Animation Not Displaying

Posted: Sun May 05, 2013 10:58 pm
by mililani
louis94 wrote:Might also be related to the AMD proprietary drivers, or to the oxygen-gtk widget style.


Thanks! That seems to be indeed the case. Switching from oxygen-gtk to the other style installed by default (Raleigh) does the trick. :!:

Re: Combat Animation Not Displaying

Posted: Mon May 06, 2013 5:19 pm
by louis94
Reported here
See also: this about Freeciv and Oxygen

Feedback from the Oxygen team:
Setting

Code: Select all

export OXYGEN_DISABLE_INNER_SHADOWS_HACK=1

before running Freeciv make animations work.

Louis

Re: Combat Animation Not Displaying on Kubuntu with Oxygen t

Posted: Tue May 07, 2013 7:34 pm
by JTN
Excellent, thanks for digging that up. I've edited the first post to point to this explanation/workaround.

Re: Combat Animation Not Displaying on Kubuntu with Oxygen t

Posted: Tue May 07, 2013 11:16 pm
by mililani
Just as an addendum: while both methods work fine on my laptop, my desktop with two monitors still exhibits the problem, no matter how I set the environment variable or change the GTK theme.