Page 1 of 1

Issue with ZLIB

Posted: Sat Aug 06, 2016 9:12 pm
by sabelo27
Hello everyone.

I trying to install freeciv in Fedora24.

/configure gives this error message:
Could not find zlib


I have installed this package, but i still get the same error message.

thank you in advance for your assistance.

Sabelo

Re: Issue with ZLIB

Posted: Sat Aug 06, 2016 9:41 pm
by sveinung
Does Fedora separate the headers from the binaries? If it does: did you install the headers?

Re: Issue with ZLIB

Posted: Sun Aug 07, 2016 5:00 pm
by sabelo27
Thank you sveinung for your response.

The headers were missing. Thank you once again.

Now make gives this following error
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /home/sabelo/freeciv-2.5.5/bootstrap/missing aclocal-1.14 -I m4 -I dependencies/m4
/home/sabelo/freeciv-2.5.5/bootstrap/missing: line 81: aclocal-1.14: command not found
WARNING: 'aclocal-1.14' is missing on your system.
You should only need it if you modified 'acinclude.m4' or
'configure.ac' or m4 files included by 'configure.ac'.
The 'aclocal' program is part of the GNU Automake package:
<http://www.gnu.org/software/automake>
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
<http://www.gnu.org/software/autoconf>
<http://www.gnu.org/software/m4/>
<http://www.perl.org/>
Makefile:757: recipe for target 'aclocal.m4' failed
make: *** [aclocal.m4] Error 127


I reinstalled all these programs autoconf, m4 and perl.

Please help

Re: Issue with ZLIB

Posted: Sun Aug 07, 2016 5:59 pm
by cazfi
sabelo27 wrote:The 'aclocal' program is part of the GNU Automake package
Have you installed automake?

Are you building from a freeciv tarball or svn checkout? Or, more specifically: have you run autogen.sh? Usually you don't need tools like automake, autoconf, and libtool (next one you're likely to encounter) if you build from tarball using provided configure script. However, if you generate configure yourself with autogen.sh, you need all the tools for the job.