Page 1 of 1

trunk won't start

Posted: Sun Nov 03, 2013 1:49 pm
by mixcoatl
I haven't been able to start the trunk version of freeciv since at least a few weeks. In the past I used to be able to start it with ./fcser and ./fcgui but if I do that now and I start a game it won't start:

Lost connection to server (server disconnected)

You were rejected from the game: The client is missing a capability that this server needs. Server version: 2.5.99-dev Client version: 2.5.99-dev. Upgrading may help!

Client capability string: +Freeciv.Devel-2.6-2013.Oct.30

Server capability string: +Freeciv.Devel-2.6-2013.Sep.27

I use the gtk-2.0 client.

Did something change? I deleted and re-installed everything but it still doesn't work. Does anybody know how I can get it to work again?

Re: trunk won't start

Posted: Sun Nov 03, 2013 2:54 pm
by cazfi
mixcoatl wrote:Client capability string: +Freeciv.Devel-2.6-2013.Oct.30

Server capability string: +Freeciv.Devel-2.6-2013.Sep.27

You are trying to connect old server. Most likely this means that you're not (since about Sep.27) been rebuilding server for some reason. Less likely explanation is that you have also old server around you connect to instead of correct one.