2.4.0-RC2 release notes

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
User avatar
Arbogast
Elite
Posts: 412
Joined: Tue Jul 16, 2013 9:09 am
Location: France

2.4.0-RC2 release notes

Postby Arbogast » Mon Sep 02, 2013 3:39 pm

In the list of changes since RC1 I found in the wiki link
It was not possible to install Freeciv using the default (en_US) translation on a non-English version of Windows (although it was possible to use British English, en_GB). GNA#21059
which is not true.

The default windows installation installs the GTK2 .exe file. By changing it to the .cmd file in the properties tab, you CAN then add the 'en_US' tag and it works just fine.
This, of course, for non-english version of Windows.

User avatar
JTN
Elite
Posts: 462
Joined: Wed Jan 30, 2013 12:15 am

Re: 2.4.0-RC2 release notes

Postby JTN » Mon Sep 02, 2013 7:42 pm

(Moved from announcement topic.)
Arbogast wrote:In the list of changes since RC1 I found in the wiki link
It was not possible to install Freeciv using the default (en_US) translation on a non-English version of Windows (although it was possible to use British English, en_GB). GNA#21059
which is not true.

The default windows installation installs the GTK2 .exe file.

Not by design, and not for me. Why it does this for you is still a mystery to me.

By changing it to the .cmd file in the properties tab, you CAN then add the 'en_US' tag and it works just fine.
This, of course, for non-english version of Windows.

Fine, I've updated the NEWS page to be more accurate; the intention is that in RC2 you'll be able to select it from the installer, not faff around with shortcuts. (Modulo the mystery of why you ended up with an incorrect shortcut.)

User avatar
Arbogast
Elite
Posts: 412
Joined: Tue Jul 16, 2013 9:09 am
Location: France

Re: 2.4.0-RC2 release notes

Postby Arbogast » Tue Sep 03, 2013 1:15 pm

Just to make sure I wasn't doing anything wrong, I installed a new 2.4.1-RC1 in another disk. During installation I was asked the language of my choice and chose 'en_GB' and couldn't change to 'en_US' everything was in its default settings. When done with the installation I quit without lunching the game.
Lunched the .exe from the Start menu and I got the french version. The .cmd doesn't lunch.
Important Note: I use Total Commander from Ghisler.com as a windows browser and that's how I was able to modify the .exe file to the .cmd file. You can't do it from the default windows browser. It doesn't show the properties tab.

(Modulo the mystery of why you ended up with an incorrect shortcut.)

So, what's the correct shortcut?
In the Freeciv Folder, the exe file shows with the bronze globe icon. The cmd file does not. So if anybody wanted to create a shortcut he-she would choose the exe file, naturally. And that was the origin of my woes.