Freeciv server does not start (2.5.9, MacOS 10.12.6, Fink)

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
vbl
Posts: 3
Joined: Sun Sep 02, 2018 7:32 pm

Freeciv server does not start (2.5.9, MacOS 10.12.6, Fink)

Postby vbl » Sun Sep 02, 2018 7:36 pm

Hi, after installing this (not completely new) version using the fink distribution for MacOS, I found that the freeciv-server will not start, with the following error:

> freeciv-server
This is the server for Freeciv version 2.5.9
You can learn a lot about Freeciv at http://www.freeciv.org/
0: Server: bad address: <(none):5556>.

This does not sound too cryptic, but what might be the reason?

Best wishes
Volker Blum

User avatar
mir3x
Veteran
Posts: 110
Joined: Sat Jan 30, 2016 6:17 pm

Re: Freeciv server does not start (2.5.9, MacOS 10.12.6, Fink)

Postby mir3x » Mon Sep 03, 2018 9:15 pm

Looks like it cannot use any network address or maybe given port is used.
try:
freeciv-server -b 127.0.0.1
or
freeciv-server -p 15550

Probably server is badly built, try that Mac installers from here : viewforum.php?f=4 ?

vbl
Posts: 3
Joined: Sun Sep 02, 2018 7:32 pm

Re: Freeciv server does not start (2.5.9, MacOS 10.12.6, Fink)

Postby vbl » Sun Sep 09, 2018 2:08 am

Thank you! Yes, it seems that changing the port or the host do not help. Will try with a different build.

Well, nethack from the same source also does not work so I am out of options!

Best wishes and thanks again!

vbl
Posts: 3
Joined: Sun Sep 02, 2018 7:32 pm

Re: Freeciv server does not start (2.5.9, MacOS 10.12.6, Fink)

Postby vbl » Sun Sep 09, 2018 2:15 am

The Mac installer for 2.6.0 did work - thank you!