Problem installing 2.6.2

You can get help here if Freeciv doesn't start on your computer, or if you keep getting fatal errors while playing etc.
Saturnina39
Posts: 4
Joined: Sat Feb 29, 2020 4:52 am

Problem installing 2.6.2

Postby Saturnina39 » Sat Feb 29, 2020 4:59 am

Hello, I want to install version 2.6.2 (the latest) on Linux Mint 19.1. As I've already checked, I have GTK 3.22 installed, but I still get this when I type ./configure:

checking for GTK3... no

and later this:

checking for GTK+ - version >= 2.12.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GTK+ is incorrectly installed.

I've been battling with this all day now, but I'm a newbie in terms of this stuff. Can someone tell me what am I missing?

User avatar
Caedo
Elite
Posts: 493
Joined: Sun Feb 10, 2013 10:21 pm
Location: Stuttgart, Germany

Re: Problem installing 2.6.2

Postby Caedo » Sat Feb 29, 2020 6:47 am

GTK 3.22 and GTK 3 are, broadly speaking, two different things. Newer (as in, non-stable) Freeciv versions come with dedicated GTK3.22 client clode, but for older ones, you'll need a GTK3 installation that's not GTK3.22.

Saturnina39
Posts: 4
Joined: Sat Feb 29, 2020 4:52 am

Re: Problem installing 2.6.2

Postby Saturnina39 » Sat Feb 29, 2020 2:11 pm

Thank you for the quick answer!

Newer (as in, non-stable) Freeciv versions come with dedicated GTK3.22 client clode

Yeah, my INSTALL file specifies a separate 3.22 client, that's why I thought I could use my 3.22.30.

you'll need a GTK3 installation that's not GTK3.22.

Is there a way to install GTK3 that doesn't involve compiling each dependency? Because I've had quite a few troubles with that yesterday (mainly with the gtk ./configure not detecting the dependencies installed).

User avatar
Caedo
Elite
Posts: 493
Joined: Sun Feb 10, 2013 10:21 pm
Location: Stuttgart, Germany

Re: Problem installing 2.6.2

Postby Caedo » Sat Feb 29, 2020 3:34 pm

On my (age-old) Ubuntu laptop, I was able to install the proper prebuilt libraries for all the GUI clients without needing to compile anything myself, so I'm afraid I can't help with that :/

cazfi
Elite
Posts: 1776
Joined: Tue Jan 29, 2013 6:54 pm

Re: Problem installing 2.6.2

Postby cazfi » Sat Feb 29, 2020 11:14 pm

The difference between gtk3-client and gtk3.22-client is that latter requires gtk+-3.22, and takes advantage of it. gtk3-client can be built with gtk+-3.22, but behaves the same with is as with any gtk+ version it supports (starting from 3.8).

You are probably missing gtk+-3 development files (separate '-dev' package that you should install in addition to the main library package you use when running the programs that use gtk+-3). In any case the 'config.log' file should contain more details about the issue. Please attach it here if you still can't figure out what's wrong.

Saturnina39
Posts: 4
Joined: Sat Feb 29, 2020 4:52 am

Re: Problem installing 2.6.2

Postby Saturnina39 » Sat Feb 29, 2020 11:33 pm

You are probably missing gtk+-3 development files

I've tried to install development files it still tells me I have the latest already installed.

In any case the 'config.log' file should contain more details about the issue

Yeah, I'll attach the file to this post. I'm kind of new to forums, so I hope I do it right.
Attachments
config.log
(137.99 KiB) Downloaded 20 times

User avatar
JTN
Elite
Posts: 473
Joined: Wed Jan 30, 2013 12:15 am

Re: Problem installing 2.6.2

Postby JTN » Sun Mar 01, 2020 1:33 pm

I don't know Mint, but Wikipedia tells me that Linux Mint 19.1 is based on Ubuntu 18.04LTS, for which the relevant package you need to install (that is, the package containing the files "gtk+-3.0.pc" and "gtk.h") is called libgtk-3-dev (with something like "sudo apt install libgtk-3-dev", or whatever other method you normally use to install packages from the Mint repositories).

(This is as opposed to the package "libgtk-3-0", which you probably already have installed; that contains the libraries you will need to run Freeciv, but is not enough for you to build Freeciv from source code.)

If that's right, then Mint's Gtk3 version is 3.22.30, which is sufficient to let you build either the Gtk3.0 or Gtk3.22 Freeciv client (or both).

I suspect this won't be the last dependency package you'll need installed. In general, it's worth trying the wiki instructions for Debian-style distributions (but I don't know if that "apt-get build-dep" command will do anything useful on Mint specifically).

Caedo wrote:GTK 3.22 and GTK 3 are, broadly speaking, two different things. Newer (as in, non-stable) Freeciv versions come with dedicated GTK3.22 client clode, but for older ones, you'll need a GTK3 installation that's not GTK3.22.

Corrections:
  • The Gtk3.22 client is available in stable (2.6.x) Freeciv releases;
  • The Gtk3.0 client (e.g. in the older Freeciv 2.5.x) should compile fine against Gtk3.22 or later, so if you specifically want to use it for some reason, there's no need to go out of your way to install an old version of the Gtk3 library;
  • As of 2.6.2, I'm hoping that the Freeciv Gtk3.22 client works at least as well as the Gtk3.0 client on modern Linux (if not better), and that there's no reason to specifically want the Gtk3.0 client (although it is still the default build target).

Saturnina39
Posts: 4
Joined: Sat Feb 29, 2020 4:52 am

Re: Problem installing 2.6.2

Postby Saturnina39 » Mon Mar 02, 2020 6:11 am

Ok, so, long story short: I had a much bigger issue at hand that got me stuck in emergency mode. After a whole day of messing around with different possible solutions I had to reinstall Linux MInt.

After that, and installing a few development libraries (libcurl, gtk3 and a couple more that the ./configure asked for) I was suddenly able to install Freeciv 2.6.2 without any issue.