PBEM Late game performance

Web version of freeciv at play.freeciv.org
Jeremy
Posts: 2
Joined: Sun Apr 24, 2016 8:07 pm

PBEM Late game performance

Postby Jeremy » Sun Jun 12, 2016 8:48 pm

First off - thank you very much for creating and making this game available. This variation of Civ reminds me of all the hours I spent playing CivNET back in the day.

So I am playing PBEM game and I am to the point in the game where I have researched all tech, have farmland on most of my tiles, etc. I noticed that there were performance issues about the time I started using farmland. The game still loaded successfully and played great once loaded. As my CIV progressed I had issues with the browser crashing. I noticed this was most likely running the 32 bit version and associated memory constraints. So I started using Firefox 64 bit and it became stable again for another 10 or so turns.

Now I am at a point where the game appears to load but not all the functionality is available. I can cycle through my cities using 'W' but I am unable to use 'R' or 'I' to build roads. In fact all the unit functions have stopped working. I cannot use GOTO for my units.

If go into a city then I cannot switch scientists to taxmen. I am also not able to complete a turn. When I hit Done, the Done button dims out but the turn never finishes.

When I start the game the memory goes up to about 4 GB and then after the load the memory usage settles down around 600 MB. This issue is not browser specific. It occurs in FireFox, Chrome and Edge. I attempted to verify in Safari, but it appears that is not an option any more for Windows.

My PBEM partner can load her game just fine, she has run into the performance problems. She is also just learning the game so none of her cities have gotten as far as mine have. She is still doing normal irrigation and has just started railroads.

Thank you for any information you can provide. I'd love to help diagnose this issue further, just let me know what more information I could provide.

User avatar
AndreasR
Elite
Posts: 701
Joined: Thu May 02, 2013 10:26 pm
Location: Norway

Re: PBEM Late game performance

Postby AndreasR » Mon Jun 13, 2016 5:45 pm

I have released a fix for this to the production server. The problem was that there were so many messages added to the chat message window, that it took up all the CPU usage. Can you please try again now, and see if the problem has been fixed?

It is quite impressive to have completed 174 turns in a Freeciv-web PBEM game! Please report any further bugs you find, and I will try to fix them!

Andreas

Jeremy
Posts: 2
Joined: Sun Apr 24, 2016 8:07 pm

Re: PBEM Late game performance

Postby Jeremy » Wed Jun 15, 2016 1:18 am

WOW!! Thank you for the quick response Andreas. The game loads insanely fast now. What was the fix if you don't mind me asking?

thx