save glitch

Web version of freeciv at play.freeciv.org
User avatar
JTN
Elite
Posts: 473
Joined: Wed Jan 30, 2013 12:15 am

Re: save glitch

Postby JTN » Fri Feb 26, 2016 12:23 am

The "alien heads" are Moai-type statues that appear in the larger Polynesian-style city graphics. They're not dependent on buildings like Granary. source

Nothing to do with save glitches, anyway.

User avatar
XYZ
Elite
Posts: 369
Joined: Fri Jan 31, 2014 12:00 pm

Re: save glitch

Postby XYZ » Fri Feb 26, 2016 9:56 am

Deduced wronlgy. Checked it, they appear with city size 8.

Elder Grendel
Posts: 5
Joined: Sun Apr 03, 2016 8:12 pm

Re: save glitch

Postby Elder Grendel » Sun Apr 03, 2016 9:24 pm

In the interest of keeping things in the same thread I'm posting this here. It appears to be related to the original post.

I've been playing multiplayer games with my son and we've had a very similar save problem: at some point in playing something goes wrong with saving the game. It does exactly what was described by the original poster: every saved game after a certain point (we'll call this T10, just for the sake of example, the actual bug is not turn dependent in any way) every save is a save of T10.

There are some things that seem to happen when it has occurred:
For instance, I can tell that the problem has occurred if I attempt to save a game and, while in the save dialog, I try to use the arrow keys to move the cursor. If the arrow keys will move the cursor, the bug has not occurred and the save will work properly, i.e., it will save the correct turn, rather than some earlier turn. If I cannot move the cursor with the error keys the bug has occurred and the save may appear to work correctly but the actual save will be some previous turn.
Also, after the bug has occurred, there sometimes seems to be an issue with moving units with the numeric keypad keys.
There also seems to be a problem with using [Shift]+[Enter] to end the turn.

Interestingly, we have just noted that if we go to the [Nations] tab and click the other Human player's Civilization, then click [Meet Player] the save game bug happens immediately. Every time. I tested this by opening the save game dialog immediately prior to opening the diplomacy menu and moving the cursor with the arrow keys, then opening the diplomacy menu and both creating a treaty and canceling the meeting (on separate tests), the immediately returning to the Save Game dialog to find I was unable to move the cursor with the arrow keys. I did not actually save the game and open the save, or continue to play and save later, but the inability to move the cursor with the arrow keys appears to be a sure indicator that the save bug will occur.

It is possible that this started as a result of some other event, though. I think, but I am not certain, that we were able to create an alliance in one or more of our previous games without it causing the bug. I could be wrong about this because we didn't notice the save bug immediately.

I have cleared the (Firefox (45.0) on Linux Mint) browser cache on both machines and deleted all of the saved games repeatedly and the issue continues.

At this point it is 100% reproduceable: Clicking [Meet Player] for another human player will cause this save game problem. I have not checked to see if the future saves are for the save that the cursor movement issue occurs on, or some previous save. I am guessing that it is the save where the cursor problem occurs, but, again, I have not actually checked this.

I have not attempted to reproduce the issue in a single-player game yet. I can say that it has not occurred in a single-player game when an AI player makes the initial contact in the diplomacy event. I honestly have not attempted to contact an AI player in a single or multi-player game at this time.

Edit: Just to clarify, we are playing on play.freeciv.org. We have not tried DLing the game and playing it on our LAN.

User avatar
AndreasR
Elite
Posts: 701
Joined: Thu May 02, 2013 10:26 pm
Location: Norway

Re: save glitch

Postby AndreasR » Mon Apr 04, 2016 8:38 pm

Thanks for the detailed bugreport, Elder Grendel.

I have tried to create a fix for this savegame problem. Can you please try to reproduce the problem again now, to see if it has been fixed? This is the fix change. Please clear your browser cache before trying again.

If you still have the problem, could you please give a detailed description about which steps to make to reproduce the problem?
(A screen-recording uploaded to youtube would be very nice!)


Andreas

mooreinstore
Posts: 20
Joined: Thu Mar 19, 2015 2:00 pm
Location: Bradley, Illinois
Contact:

Re: save glitch

Postby mooreinstore » Tue Jul 05, 2016 8:35 pm

I'm getting the save glitch again. It's the same as before only on a new laptop using the new Microsoft Edge browser instead of Google Chrome.