Page 1 of 1

Does the client need to be in the same version than the server?

Posted: Mon May 14, 2018 8:00 pm
by dareg
Hi everyone,

I am trying to set up a multiplayer game on my own server.
I can install from the debian repo the freeciv server in the version 2.5.11 or 2.5.6.
Some of the players can install 2.5.11 and some others can only install 2.5.6.
Which version version should I prefer for the server?
Can 2.5.6 clients play without problems on a 2.5.11 server?

Re: Does the client need to be in the same version than the server?

Posted: Mon May 14, 2018 8:20 pm
by Caedo
I think servers and clients of the same major version (2.5) should be compatible regardless of the minor version (.6 or .11).

Re: Does the client need to be in the same version than the server?

Posted: Wed May 16, 2018 6:16 pm
by dareg
Ok, thanks for your answer Caedo.