Graphics bugs in Freeciv on Mac OS

Contribute, display and discuss art and tilesets for use in Freeciv here.
nctrd
Posts: 4
Joined: Thu Dec 28, 2017 11:23 am

Graphics bugs in Freeciv on Mac OS

Postby nctrd » Thu Dec 28, 2017 11:39 am

Dear freecivers,

I've installed Freeciv gtk2 from source on Mac OS Sierra, 10.12.6 and got two issues, which look the same in freeciv 2.5.9, 2.5.8, 2.6.0, 2.5.2 and maybe other:

- Font settings for city production seem to be ignored. The client starts with font size of something like 6, despite the fact that it's 13 in the settings.
I've had freeciv 2.3.0 installed from precompiled dmg, and did not flush the ~/.freeciv folder - could that be the reason?

- Unit movement animations are missing. On the goto command (G+mouse click), the selected unit teleports from A to B, other then visiting all of the tiles in between. Noteworthy, the game freezes between the initial and final states for roughly (unit movement animation time)*(number of steps).

Where should I look for the solution? Which library or setting can be responsible? The issue seems to be barely googleable.

The OXYGEN_DISABLE_INNER_SHADOWS_HACK=0 hack (found at some forum) does not work.
My shared libs are from homebrew.

Please consider the configure, make and make install dump - if that can be of any help.

Thank you very much in advance.
Andrew
Attachments
freeciv-2.6.0-beta1-configure-make.txt
(136.49 KiB) Downloaded 8 times

User avatar
mir3x
Veteran
Posts: 96
Joined: Sat Jan 30, 2016 6:17 pm

Re: Graphics bugs in Freeciv on Mac OS

Postby mir3x » Thu Dec 28, 2017 7:06 pm

nctrd wrote:
- Font settings for city production seem to be ignored. The client starts with font size of something like 6, despite the fact that it's 13 in the settings.
I've had freeciv 2.3.0 installed from precompiled dmg, and did not flush the ~/.freeciv folder - could that be the reason?

Default font is Serif here, either MacOs doesnt default to any Serif or it took that setting from 2.3 and that font family which doens't exist anymore ?
Try changing font family.
- Unit movement animations are missing. On the goto command (G+mouse click), the selected unit teleports from A to B, other then visiting all of the tiles in between. Noteworthy, the game freezes between the initial and final states for roughly (unit movement animation time)*(number of steps).

It's something with gtk2 libs, but it looks like well known gtk3 client issue. Maybe upgrade or downgrade them.

nctrd
Posts: 4
Joined: Thu Dec 28, 2017 11:23 am

Re: Graphics bugs in Freeciv on Mac OS

Postby nctrd » Tue Jan 02, 2018 10:30 am

As of now, I have deleted XQuartz and reinstalled freeciv 2.5.9 from homebrew. Did not help.

Here are my gtk-related packages, from "brew search gtk", installed ones are marked.

gtk+ ✔ gtk-mac-integration ✔ gtkmm ✔ gtk-gnutella gtksourceview gtkspell3
gtk+3 ✔ gtk-murrine-engine ✔ pygtk ✔ gtk-vnc gtksourceview3 lablgtk
gtk-chtheme ✔ gtkextra ✔ clutter-gtk gtkdatabox gtksourceviewmm pygtkglext
gtk-engines ✔ gtkglext ✔ gtk-doc gtkmm3 gtksourceviewmm3 pygtksourceview

Noteworthy, problem is present despite installing gtk-mac-integration, gtk-engines, gtk-murrine-engine, gtkextra, gtkglext, gtkmm, pygtk.

I export GTK_PATH=/usr/local/lib/gtk-2.0, which fixed gtk " Unable to locate theme engine in module_path: " warnings, but the units in freeciv still teleport.

I did not mention it previously, but the sound of unit movement is played with (unit move animation time) period, and then the unit teleports. So, the problem is stricktly graphics-related and not imagemagick-related (the latter I found out earlier).

nctrd
Posts: 4
Joined: Thu Dec 28, 2017 11:23 am

Re: Graphics bugs in Freeciv on Mac OS

Postby nctrd » Wed Jan 03, 2018 5:34 pm

Another small UPD:

Sometimes mouse cursor does not become the spinning circle and I cannot click on anything. Heals after some map scrolling. Also, I keep getting the following warning:

(freeciv-gtk2:5013): Gdk-WARNING **: Source with depth 1 unsupported

nctrd
Posts: 4
Joined: Thu Dec 28, 2017 11:23 am

Re: Stable release 2.5.10

Postby nctrd » Fri Feb 09, 2018 12:41 pm

[moved from Announcement forum -- JTN]

I'd like to report that this release still* exhibits animation issues on Mac OS Sierra, gtk 2.24.32, both homebrew and compiled-from-source versions. Namely, other then move over the map, the units wait for (unit movement animation time)*(number of steps) and then teleport to the end position. Combat animations are missing too, probably due to the same issue.

*The issue is present in 2.5.* and 2.6-beta branches.